import Foundation
let pattern = #"(\t+)(.+\|)(\n)((\1\t)(.+)(\n)+)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
win_shell: |
Move-Item -Path "C:\OldPath\*.dat" -Destination "C:\NewPath\"
info
info
info
some info
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)