use strict;
my $str = 'u2x4m5x7';
my $regex = qr/(\d+x)|./mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";