use strict;
my $str = 'lorem ipsum lorem ipsum <FONT COLOR="#FF0000">&lt;csf style="Italic CH" &"italic="on"&gt;</FONT> lorem ipsum
some " here and here " as well';
my $regex = qr~(?:\G(?!\A)|FONT)
(?:(?!FONT).)+?\K
(?<!&)"~mxp;
my $subst = '&quot;';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";