$re = '/(.*\.net)[^\?#]*(.*)/im';
$str = 'https://apfelschuss.azureedge.net';
$subst = "$1/index.html$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;