re = /((?:[^\?]*\/)?)($|\?.*)/im
str = 'myawesomefolder/posts/?query=string
'
subst = '$1index.html$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result