$re = '/input.*?name=(?\'name\'[^ ]+)/m';
$str = '<input name=dir value=">">
<input value=">" name=dir >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);