# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bF[A-Z]{0,2}\b//gm;t' <<< "F
FA
FB
FAA
FAAA"