package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bF[A-Z]{0,2}\b`)
var str = `F
FA
FB
FAA
FAAA`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}