$re = '/\bF[A-Z]{0,2}\b/m';
$str = 'F
FA
FB
FAA
FAAA';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;