re = /^(?:\d.|[*+-]) [^]*?(?=^(?:\d.|[*+-])|$(?![^]))/m
str = '1. text
2. text
1. text
2. text
* text
* text
- text
+ text
1. text
* text
1. text
* text
1. text
* text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end