use strict;
my $str = 'Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
';
my $regex = qr/.+((?<=Colombo: ).+)[\s|\S]+((?<=TestL: ).+)[\s|\S]+((?<=Restric: ).+)/mp;
my $subst = '$2:$3@$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";