$re = '/((CAV-\d\s)[AGCT]+)(?:\n\2[AGCT]+)*/';
$str = 'CAV-1 ATCTACTTCTATCG
CAV-2 GCGCGTAGCTAGCT
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-2 AAGCGCTCGTAAAA
CAV-3 AAATATATATATCC';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;