package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\\.|[^|\\]+)+`)
var str = `|123|create|item|1497359166334|Football|Some League|\|Team\| vs \|Team\||1497359216693|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}