Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<![;\{\}]|\*\/|\s*\/{2}.*?)$
/
gm
Input 1
1
New
let app = nothing; /* main function */ if (something) { // this will be the eroor const error = "ough-ough!" }
Substitution
;