re = /^(?<DateTime>[^,]*),(?<username>[^,]*),(?<Action>[^,]*),(?<Entity>[^,]*)/m
str = '2022-11-21 15:44:13,ea186520,CREATED,USERSESSIONLOG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end