using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@.+k\s[[].+[\][msg:\s""].+""[\]]";
string input = @"@block [user][msg:
""you messagnbb""]
nnbb @block [hello][msg:""no""]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}