using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z](?!.*(['-]).*\1)(?!.* )(?=.{0,19}$)[a-zA-Z'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z'-]*)*$";
string input = @"This is aa
This is aa test
aa aa aa aa aa aa aa
This should m'atch
This a-lso'
This is a test
a b
aa
a
This is 4 test
This is aa test
This' is aa tes
This is aaaa longer test
This sh'o'uld not
This sh-o-uld not
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}