use strict;
my $str = 'http://localhost:3000/#/reconciliation/historyRecord/list?cr-dz=start~type=0&result=&hospitalId=123&reconciliationStartDate=2021-05-05%2000%3A00%3A00&reconciliationEndDate=2021-05-05%2000%3A00%3A00&ifPage=true&page=1&limit=10~end';
my $regex = qr/(?<=start~)(.+)(?=~end)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}