import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\s(\\d+\\.\\d+\\s+)\\s+(\\d+\\.\\d+\\.\\d+)\\s+(?P<XYZ>.*$)";
final String string = " \n"
+ " Number of surface maxima: 7\n"
+ " # a.u. eV kcal/mol X/Y/Z coordinate(Angstrom)\n"
+ " 1 21.76342476 592.21290413656.766669 -6.892053 -0.425961 -0.514519\n"
+ " 2 21.95275305 597.36478913775.572064 -6.167357 1.713169 -0.882468";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}