use strict;
my $str = 'app/service/namespace/important_thing/my_class.rb
D:\\app\\service\\namespace\\important_thing\\my_class.rb';
my $regex = qr/^(?:.*?[\\\/])?app[\\\/]\w+[\\\/]|([^\\\/\n]+?)(?:\.rb$|([\\\/]))/mp;
my $subst = '<$1>[$2]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";