use strict;
my $str = '6.933141
5.13
1.56
2.94
1.54
6.470931';
my $regex = qr/^(\d+\.\d{2})\d+$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";