Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?<sign>[+-])?\d+(?:\.?\d+)?(?<percent>%)?$
/
mg
Input 1
1
New
50 -50 +50 50% +50% -50% 50.50.50 +-50% -50.% 4.%