package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|1[012]):(0[0-9]|[1-5][0-9])\s?(am|AM|pm|PM)$`)
var str = `1:00am
10:00am
10:00pm
12:54am
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}