use strict;
my $str = 'From: john@workplace.com
Sent: Thursday, 23 May 2019 7:14 AM
To: Team Inbox
Subject: Send me some more cookies';
my $regex = qr/(?<=Sent: Monday, |Tuesday, |Wednesday, |Thursday, |Friday, |Saturday, |Sunday, )(\d\d\s|\d\s)(January |February |March |April |May |June |July |August |September |October |November |December )(20\d\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}