$re = '/(?:Anakinra)\s*(\d+(?:[.,]\d+)*)\s*(g|mg|)/m';
$str = 'Anakinra 100 mg, gentechnologisch hergestellt aus E. coli.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);