package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^| )text($| )`)
var str = ` text .text. 'text'
text .text. 'text'
text .text. text 'text'
text .text. text 'text' text
text .text. text 'text'text
text
text
text
edittext stext
edittext stext
textedit`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}