re = /((?:\.(?!mp3)|[!&^?:;\/]))/m
str = 'Hello! Here is a file. It is called beatles.mp3. And so on!'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result