import Foundation
let pattern = #"((?:\.(?!mp3)|[!&^?:;/]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Hello! Here is a file. It is called beatles.mp3. And so on!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)