$re = '/(?<=\().+?(?=\))/m';
$str = 'x^(3*x+1) + (cos x)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;