use strict;
my $str = '[Honoraires inclus]
REGEX = honoraires?(\\s(d\\\')?agences?)? inclus?
honoraires d\'agence inclus
honoraires agence inclus
honoraires inclus
[Hors Honoraires]
REGEX = (hors\\s)?honoraires?(\\sexlus?)?
hors honoraires
honoraires exclus
=> https://colab.research.google.com/drive/1pcExD9IQfGtDWp868WhSWJP_Wsdev3QE#scrollTo=bhe-zIRlpOyx';
my $regex = qr/honoraires?(\s(d\')?agences?)? inclus?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}