$re = '/^(?!(?:[^|\n]*\|){2})[^<>@#\n]+$/m';
$str = 'Some |text
Some | text
Some <text
Some |text| text
Some |
||
|ddddd|
|d
ddd|
d
|
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);