# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b0|([0-1])(?=0*~[0-1]*?\1([0-1]))|~[0-1]*/$2/g;t' <<< "0101~010"