use strict;
my $str = 'import sdf from \'./sdf\'
from "./hello"
from "./hello\'
import "./sdsd"
const img = require( `src/sdfsdf${name}.png`)
const img = require( `../../${name}.png`)
const img = require.context( `../../${name}.png`)
import "./sdsd"
import {} from \'./sdsdsd\'
import {} from "../sdsdsd"
// import("./sdfsdf");
import("./sdfsdfsdf");
const foo = import(\'../sdf\');
// require
const images = require(`./sdfsdf${namme}`);
require( \'./sdfsdf\' );
// require.context
require.context("./sdf"
const sdf= await import(\'./sdfsdf\')
const aa = require(\'./sdfsdf\')
const aa = require(`./sdfsdf/${abc}`)
const aa = require(\'./sdfsdf/\')
// export from
export * from \'./interface\'
import(`./sdf${1}`)
import(`./sdfsdf")
const dfdf = \'../sdfsdfsdf\'
let fpath = \'src/modules/\' + name';
my $regex = qr/(?<=\W(from|import|require\(|require\.context\(|import\()\s*)['"`]((\.+|src)\/.+?)['"$`]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}