import Foundation
let pattern = #"(?<=\W(from|import|require\(|require\.context\(|import\()\s*)['"`]((\.+|src)\/.+?)['"$`]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
import sdf from './sdf'
from "./hello"
from "./hello'
import "./sdsd"
const img = require( `src/sdfsdf${name}.png`)
const img = require( `../../${name}.png`)
const img = require.context( `../../${name}.png`)
import "./sdsd"
import {} from './sdsdsd'
import {} from "../sdsdsd"
// import("./sdfsdf");
import("./sdfsdfsdf");
const foo = import('../sdf');
// require
const images = require(`./sdfsdf${namme}`);
require( './sdfsdf' );
// require.context
require.context("./sdf"
const sdf= await import('./sdfsdf')
const aa = require('./sdfsdf')
const aa = require(`./sdfsdf/${abc}`)
const aa = require('./sdfsdf/')
// export from
export * from './interface'
import(`./sdf${1}`)
import(`./sdfsdf")
const dfdf = '../sdfsdfsdf'
let fpath = 'src/modules/' + name
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)