using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&[^&=]+=(?=&)";
string input = @"something=na&rows[0][data]=0&rows[0][name]=&rows[0][indexable]=true&rows[0][searchable]=false&columns[0][search][value]=&
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}