re = /\s(?=[^,\s]*,)/m
str = 'Happy birthday, Jimmy
This is a test
This is, another test,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end