const regex = /.*?linkedin.com\/[a-z A-z 0-9]+\/([a-z A-z 0-9 -]*)\/*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?linkedin.com\\\/[a-z A-z 0-9]+\\\/([a-z A-z 0-9 -]*)\\\/*', 'gm')
const str = `https://www.linkedin.com/in/gregory-kovalchuk-5869946a/
linkedin.com/in/devin-slattery-94342992`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}