re = /.*?(?:(?:[0-9]{2}[\/-]){2}[0-9]{4}|[0-9]{4}(?:\h[0-9]{4}){2}).*/m
str = '10/02/1992
10/02/1992 or 1992
10/1992
02/1992
1992
1234 5694 7487
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end