$re = '/(?!0)\d+/m';
$str = '0
1
2
5
10
20
42
50
69
100
1337';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);