// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9]{1,2}[\/][0-9]{1,2}[\/][0-9]{1,4}) ([0-9]{1,2}:[0-9]{1,2}) - ([a-z0-9 \S]+?:)([a-z0-9 \S]+?\n)").unwrap();
let string = "25/03/2017 09:32 - Diego Rhoger criou o grupo \"CerradoValley\"
27/04/2017 15:42 - Você entrou usando o link de convite deste grupo
27/04/2017 15:43 - +55 61 9332-2990: Valeu 👍🏻
27/04/2017 15:43 - Fabiano S Figueiredo: 🙃👍
27/04/2017 15:43 - Dartagnan Sabino Antunes Oliveira entrou usando o link de convite deste grupo
27/04/2017 15:44 - Fabiano S Figueiredo: e aí gente, tudo bem?
27/04/2017 15:44 - Fabiano S Figueiredo: Onde e como saber quem é quem? :D
27/04/2017 15:44 - +55 61 9332-2990: No decorrer das conversas vc vai conhecendo o pessoal rs
27/04/2017 15:45 - Fabiano S Figueiredo: né? :)
27/04/2017 15:45 - +55 61 9869-0018: é a única forma
27/04/2017 15:45 - +55 61 9869-0018: e ir aos meetups da vida
27/04/2017 15:46 - Fabiano S Figueiredo: Jóia. E normalmente o que é discutido aqui?
27/04/2017 15:55 - +55 61 9332-2990: Discutimos sobre mercado, economia, startups, comportamento empreendedor
27/04/2017 15:55 - +55 61 9332-2990: E as vezes a gente se espanca em assuntos de religiao e política
27/04/2017 15:55 - +55 61 9332-2990: As tudo fica bem depois
27/04/2017 15:56 - Fabiano S Figueiredo: Massa!!
27/04/2017 15:56 - +55 61 9332-2990: @556181302875 apresenta aí sua startup cara com poucas palavras
27/04/2017 15:56 - Fabiano S Figueiredo: Legal!!
27/04/2017 15:56 - +55 61 9332-2990: E manda o vídeo tbm rs
27/04/2017 15:56 - +55 61 9332-2990: Bota aí pra colher a opinião da gakera
27/04/2017 15:57 - +55 61 9332-2990: A minha vc já tem 👍🏻
27/04/2017 15:57 - Fabiano S Figueiredo: Qual é a do Vídeo?
27/04/2017 15:57 - +55 61 9332-2990: É pro @556181302875 rs
27/04/2017 15:57 - Fabiano S Figueiredo: Ahh!! ups!
27/04/2017 16:01 - Dartagnan Sabino Antunes Oliveira: Boa tarde Galera! Sou o Dartagnan, analista e desenvolvedor de sistemas.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}