import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#{1,6}.*)";
final String string = "#heading 1 \n"
+ "bla bla bla\n"
+ "### heading 3 djdjdj\n"
+ "bla bla bla\n"
+ "## heading 2 bal;kasddfas\n"
+ "fbla bla bla";
final String subst = "<b>$1</b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}