import Foundation
let pattern = ##"^(#{1,6}.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$1</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)