import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?(?:_.*?){3})(?=_|$).*$";
final String string = "ABCD01MAH_processor_B_stats_qwer_20181105T105946Z.csv\n"
+ "ABCD01MAH_processor_B_stats_qwer_20181106T105945Z.csv\n"
+ "EFGHIJ01MAH_processor_A_stats_qwer_20181105T105945Z.csv\n"
+ "EFGHIJ01MAH_processor_A_stats_qwer_20181106T105945Z.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}