$re = '/\bStack Overflow\b(?:[^\.]*\.){2}/ms';
$str = 'Stack Overflow
It is great website. It works very well.Lot of people help each other.
I love it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);