re = /\bStack Overflow\b(?:[^\.]*\.){2}/m
str = 'Stack Overflow
It is great website. It works very well.Lot of people help each other.
I love it.'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end