$re = '/^\d{5}$/m';
$str = '1234
12345
123456
abcd
abcde
abcdef';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);