# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(file\s)([A-Za-z]+(?=\/|\s))(.*)(\d{3})"
test_str = ("file Science/Chemistry/Quantum 444 1\n"
"file Marvel/CaptainAmerica 342 0\n"
"file DC/JusticeLeague/Superman 300 0\n"
"file Math 333 0\n"
"file Biology 224 1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.