import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?!.{1,30}(?:\\.\\s|\\.$|\\?\\s|\\?$|;\\s|;$|。|?|;))(?:.{30}))|(?:.{1,30}(?:\\.\\s|\\.$|\\?\\s|\\?$|;\\s|;$|。|?|;))";
final String string = "美国不仅是世界上经济最发达的国家,其教育在全球也一样是顶级水平,每年发布的世界大学排名中,有很大的一部分是来自于美国。\n"
+ "但是与之卓越的教育地位相对应的是高昂的学费和生活费,这对很多普通家庭来说,无疑是天价数字。\n"
+ "除此之外,美国留学签证和入学门槛相对其它国家而言,也更为严格。美国教育的录取规则不同于中国,很多美国名校除了学生的学.\n"
+ "术背景,更看重其综合实力,比如课外活动,个人经历等.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}