import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}:\\d{2}:\\d{6,7}:\\d*";
final String string = "66:77:0066600:0000\n"
+ "66:11:0109003:627\n"
+ "66:44:0101033:378\n"
+ "66:27:1102019:25\n"
+ "66:27:1102017:6\n"
+ "66:27:1102033:93\n"
+ "66:27:1102043:21\n"
+ " : : :\n"
+ " : : :\n"
+ "66:11:180100:607\n"
+ "66:44:010101:725\n"
+ "66:16:260102:75\n"
+ "66:30:120113:163\n"
+ "66:30:120105:26\n"
+ "66:30:120106:34\n"
+ "66:30:120106:1\n"
+ "66:16:260101:3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}