#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\.1\.\d?(6[678]|7[12]|18[012567]|301)"
Local $sString = "1.1.066" & @CRLF & _
"1.1.067" & @CRLF & _
"1.1.067" & @CRLF & _
"1.1.068" & @CRLF & _
"1.1.071" & @CRLF & _
"1.1.071" & @CRLF & _
"1.1.072" & @CRLF & _
"1.1.072" & @CRLF & _
"1.1.166" & @CRLF & _
"1.1.166" & @CRLF & _
"1.1.167" & @CRLF & _
"1.1.168" & @CRLF & _
"1.1.168" & @CRLF & _
"1.1.171" & @CRLF & _
"1.1.172" & @CRLF & _
"1.1.172" & @CRLF & _
"1.1.180" & @CRLF & _
"1.1.180" & @CRLF & _
"1.1.181" & @CRLF & _
"1.1.182" & @CRLF & _
"1.1.182" & @CRLF & _
"1.1.185" & @CRLF & _
"1.1.186" & @CRLF & _
"1.1.187" & @CRLF & _
"1.1.187" & @CRLF & _
"1.1.266" & @CRLF & _
"1.1.267" & @CRLF & _
"1.1.268" & @CRLF & _
"1.1.271" & @CRLF & _
"1.1.272" & @CRLF & _
"1.1.301" & @CRLF & _
"2.1.066" & @CRLF & _
"2.1.067" & @CRLF & _
"2.1.068" & @CRLF & _
"2.1.068" & @CRLF & _
"2.1.071" & @CRLF & _
"2.1.072" & @CRLF & _
"2.1.072" & @CRLF & _
"2.1.166" & @CRLF & _
"2.1.166" & @CRLF & _
"2.1.167" & @CRLF & _
"2.1.167" & @CRLF & _
"2.1.168" & @CRLF & _
"2.1.168" & @CRLF & _
"2.1.171" & @CRLF & _
"2.1.171" & @CRLF & _
"2.1.172" & @CRLF & _
"2.1.172" & @CRLF & _
"2.1.180" & @CRLF & _
"2.1.180" & @CRLF & _
"2.1.181" & @CRLF & _
"2.1.182" & @CRLF & _
"2.1.182" & @CRLF & _
"2.1.185" & @CRLF & _
"2.1.186" & @CRLF & _
"2.1.187" & @CRLF & _
"2.1.187" & @CRLF & _
"2.1.271" & @CRLF & _
"2.1.272" & @CRLF & _
"2.1.301"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")